"OpenGL 3.3 and later is required" - How to update video card driver (Windows Only)

If you are receiving the "OpenGL 3.3 and later is required for this application to run" error message when launching or installing Photo RAW, please make sure your machine meets the minimum requirements listed here.  

If you are not sure whether or not your GPU supports Open GL 3.3 or above, please make sure you visit the manufacturers website. If your model does support Open GL 3.3 and above, updating your graphics driver will fix this error message. If this is the case, we recommend updating your GPU driver directly from the manufacturers website:

 

Update Intel Graphics Drivers

Automatically update AMD Graphics Drivers

Automatically update NVIDIA Graphics Drivers

 

How to set the default GPU (highly recommended):

After you have updated your GPU Driver from the manufacturer's website, we also recommend setting the default GPU within the AMD or NVIDIA Control Panel. Configuring the program run off of the high performance GPU will help boost performance and stability. This step is highly recommended if your machine is equipped with dual GPUs.

Please click here for instructions on how to set the default GPU.

Please note, most machines with a dedicated GPU from AMD or NVIDIA support Open GL 3.3 and above as long as this GPU was released within the last 4-5 years. If the machine to GPU is 5 or more years old, there is a possibility your GPU does not support Open GL 3.3. In this case you will need to check the specifications for your GPU model on the manufacturers website. 

 

 

 

Was this article helpful?
5 out of 23 found this helpful
Have more questions? Contact Us
Powered by Zendesk