Skip to main content

Problem launching plugins from Affinity Photo




  • Brian Lawson Community moderator

    New updates were released today. Have you tried them yet?


  • Andreas Brunn

    Yes, I did. Unfortunately nothing changed.

  • Brian Lawson Community moderator

    Have you gone through the Delete Settings and/or Reset processes? Try those and if it still is not working you should contact tech support. The programs should be opening directly when called via the plug-ins. Something isn't right but I'm a Mac guy so I can't help troubleshoot this, sorry.

  • Rick Sammartino Community moderator

    According to this article, you need to activate a plugin first. Have you done that?

  • Andreas Brunn

    I have gone through Delete Settings and Reset processes for each of the plugins -> no change.

    I have activated all the plugins by specifying the path for each as described in the help file -> no change.

    The log file c:\Users\(username)\AppData\Roaming\ON1\onOneLog.txt states the following:

    2022-11-17 22:49:51 Proxy - CPSCtrlr::Startup
    2022-11-17 22:49:51 Proxy - Attempting Connection
    2022-11-17 22:49:51 Proxy - CPSCtrlr::LaunchRemotePlugin
    2022-11-17 22:49:51 Proxy - Launch Error Error Number = 1002

  • Brian Lawson Community moderator

    That's something you'll have to talk with support about. No one here knows what the error codes mean. The plug-in attempted to launch the program but that failed for some reason.

  • Andrea Suatoni

    I've spent an hour writing a long reply with the solution to this bug that is known to ON1 support since last year, and after clicking on Submit my message vanished in the air. I will not spend another hour, so take the following for granted and ask ON1 to fix the issue for which I opened support request #289295. They know why it happens, and they haven't fixed it for plugins 2022, nor for 2023 version.

    Login to the computer with the administrator account you have used to install ON1 plugins for all the users. Open a CMD and run:

    reg export HKCU\Software\ON1 ON1.reg

    Change ON1.reg to a path where any other user can read the file.

    Now logoff and login again, this time with the user account which you want to use for running Affinity (or any other host application like PhotoShop, it doesn't matter). Open a CMD and run:

    reg import ON1.reg

    Change ON1.reg to the same path used for the export.

    You are done.

  • Andreas Brunn

    Hi Andrea,

    that did the job. Thanks a lot for providing this solution!
    I very much appreciate your effort writing another comment after your first attempt vanished in digital Nirvana. 

    Before actually following the steps you described, I checked the registry - and the reason for the failure to start the plugins is obvious if you know where to look. There is a registry entry for every ON1 executable. For the Administrator user there are the keys "ConduitExecutable" (containing the installation path of the exe file)  and some have a "FactoryContent" key (pointing to "C:\ProgramData"). Both keys didn't exist in the HKCU branch for the other user.

    After exporting HKCU\Software\ON1 to a .reg file as Administrator and importing that file when logged in with my standard user account (which applies the missing registry keys), everything works as it should have done from the beginning.

    The cause for not creating that registry keys in the correct place during installation seems to be that I chose to "install for all users" when running the setup as standard user. Of course I was then prompted to enter Administrator credentials, which is pretty normal. But I would expect "install for all users" means that all the installation procedures necessary to launch the plugins from host applications would be applied "for all users" and not just for the Administrator.

    Like you I also consider this a bug in the setup executable that really should be fixed before the next release.


  • Andrea Suatoni

    Hi Andreas,

    I am happy that it worked, and I am happy that you arrived to the same conclusions I arrived one year ago. As said, a little more than a year ago I opened a support case and I've explained to ON1 my findings and the reason it was not working. Like you've seen, it's a matter on writing the registry keys in the proper place, and HKCU IS NOT the proper place when a software is installed system wide. HKLM would be the right place, but as ON1 can work also installed in user's space (and a standard user cannot write in HKLM), I concede that the proper fix would be to check for the registry keys first in HKLM and if not found then in HKCU.

    Very easy to fix, as long as you want to fix it. I've just reminded ON1 support on the sleeping case (they have closed it without doing nothing :( ), but I would not hold my breath.

  • Rick Sammartino Community moderator

    Andrea, your solution looks like something we should add to our tips thread (item #9). Do you want to write something up, or should I just copy from your posts? It will need to be formatted like the other tips and needs a bit more explanation about the steps. Let me know.

    So, if I'm seeing it right, this procedure just exports a key as an admin and reimports it as a user. Is that right? I don't understand this though... "Change ON1.reg to the same path used for the export.". That's that for?

    Tips thread is here...


  • Andreas Brunn

    I think that should read:

    Open a CMD an run

    reg import <path_where_you_saved_exported_file>\ON1.reg 

    So if you exported the file to the folder C:\temp you would run

    reg import C:\temp\ON1.reg

    BTW you can just navigate to the folder in windows explorer and double click the file to do the very same thing.


    OT: How can I mark this thread as "answered"?

  • Brian Lawson Community moderator

    Only the moderators can make that change.

  • Andrea Suatoni


    I think you can publish something like the following, if it is OK for you. I see Andreas has already made clear my convoluted statement, sorry but English is not my primary language and additionally I was quite upset by the fact I had just lost one hour in composing a more detailed reply that went nowhere.


    Professional plugins on Windows may fail to be invoked from host applications when the plugins are installed for All Users

    When Professional Plugins 2022 (and 2023) are installed for All Users, that is system wide instead in the current user's context, the installer requires the elevation of privileges to copy the files in some protected directories. However, if the administrator account is different from the account of the user who is going to use the plugins, the plugins will not start properly.

    The reason is that the ON1 installer and the plugins code expect to read/write some some critical information in the current user's registry context, but when the installer is being elevated using a different account, the critical information will be written in that account context, not in the context of the normal user.

    ON1 is aware of this bug since a year, and yet they have no estimated time on when (and if...) it will be fixed. In the mean time the following hack will resolve the issue:

    1) Login to the computer with the user account which will use the plugins.
    2) Open an elevated Command Prompt (cmd). The easiest way is to press the Windows+R keys, write cmd in the dialog and (very important) press the Control+Shift+Enter keys. When requested, specify the same administrator account you used to install the software.
    3) Locate a directory where not only the administrator, but also all the other users can access the files. Let's say we will use C:\Temp, create it if it doesn't exist.
    4) Run the following command:

       reg export HKCU\Software\ON1 C:\Temp\ON1.reg

    5) Open now another Command Prompt, this time without elevation.
    6) Run the following command:

       reg import C:\Temp\ON1.reg

    The needed information is now being imported in the current user's context. You can store away the ON1.reg file and use it again for any other user account.

  • Rick Sammartino Community moderator

    Awesome, thanks. I've added it to the thread.

    I made one edit to remove the little 'dig' at ON1 for not fixing it. ;)

  • Andrea Suatoni

    Hey Rick, thank you for the fast follow-up.

    No problem for removing the line on ON1, even if unfortunately reflects the reality. I will not elaborate further.


Please sign in to leave a comment.