Skip to main content

ON1 2019.5 Bugs, Broken Features, and Crazy Unexpectant Behaviors

Comments

30 comments

  • Francine McKinley

    I'm uninstalling. I took my Mac Pro offline a few years ago to prevent this sort of thing and I am SO HAPPY I did! It's becoming too costly to trust updating these days.

    1
  • Brian Lawson Community moderator

    A new beta was released to Plus members this morning. Nathan Kuedall said they are hoping to release the update within a week. It is working well for me.

    1
  • Terry Loewenberg

    Worse than that, Nigel. Not only is ON1 still promoting a "not ready for prime time" release but at a lower cost than what I paid for an "upgrade" last October. 

    1
  • Terry Loewenberg

    My primary concern with 2019.5 was crashes. With the beta version installed, which did so "over" my existing 2019.5 release so I've but the beta version, I can crash the program at will. The scenario is simple. I am editing an image and am satisfied with the results. At the same time, I notice down in the strip below that there is a similar image that I no longer feel the need to retain. With my mouse, I select the planned for deletion image and tap the keyboard "Delete" key, the program pauses, the little blue ball starts rotating, and the program crashes consistently. Normally, I immediately restart ON1 PH and am greeted with the offer to submit a crash report, which I always do. I've also submitted the issue (now that I can reliably repeat it) with tech support. 

    1
  • Brian Lawson Community moderator

    They prioritize them by the number of users voting for them.

    1
  • David Kick

    Yeah Brian I figured you were aware - I added the criteria so others would understand. I have also voted for ideas and added one. Hopefully others will use the link and vote for an idea that matches theirs or add their ideas. 

    1
  • Wes Smith

    I agree ... On1 has always been one of the buggiest programs I've ever used.
    I had high hopes for the 2019.5, but it still chews CPU like crazy, constantly indexes my hard drive and is just awful compared to LR, capture 1.   I'm removing it ... again.  

     

    0
  • Terry Loewenberg

    Brian - did you completely uninstall the original 2019.5 before installing the beta? I have the beta on my desktop but want to make sure I don't muck this up. Thanks.

    0
  • Brian Lawson Community moderator

    No, I did not. I have them running side by side so I can test in both versions what users here report to see if a particular problem has been resolved yet or if I am even seeing the same problem in the released .5 version. I did however, completely blow away all my image preview cache and Catalogs to get a clean slate for testing the cataloging process and keyword issues.

    0
  • Terry Loewenberg

    Thanks, Brian. 

    0
  • Brian Lawson Community moderator

    I renamed both the ON1 PhotoRAW 2019 app and its enclosing folder to keep it in place before running the beta installer. Sorry, I should have mentioned that. I'll see if I can reproduce this issue and let you know what happens.

    0
  • Rick Sammartino Community moderator

    What does that mean 'Just be a folder'?

    0
  • Terry Loewenberg

    Brian - no apology necessary. I blindly "assumed" if I selected the "leave everything as it is" option while running the install that it would leave the old installation alone. I think what I may do is use your technique to reinstall the beta, rename the beta install, then go get a clean copy of the existing 2019.5. Hopefully, I won't wrap myself around a software axle. 

    0
  • Brian Lawson Community moderator

    Are you in edit mode or the browser when you try to delete from the Filmstrip (the previews at the bottom of the window)?

    0
  • David Kick

    Rick,  I think the comment about just a "Folder" means just showing a "Folder" icon VS an image where the folder is. I have seen this request before. Personally I don't understand the need for this as there is a folder indicator in the lower right hand side of the image which makes it obvious it's a folder and I never have subfolders mixed in with a bunch of images.

    To Nigel -- I have seen other posts where if you really want to see a Folder icon instead of a picture. Find an image of a folder add it to each folder then make that image the indicator for the folder by finding the Image and right click then choose "Set Directory Preview"   

    Personally I'd rather see On1 working on other issues than add a different folder Icon since one is in place anyway.

    0
  • Rick Sammartino Community moderator

    Ok, that's what I thought. Here is an image for a folder if anyone wants it. Just copy this into the folder and set it as Directory preview.

    0
  • David Kick

    I also have to chime in again and say that in my opinion On1 is working on responding to user requests but I think it is unreasonable for them to wok on every request that comes through and / or for them to be implemented immediatly.

    Just because 2 or 3 useres request feature X doesn't mean everyone wnats that feature.

    I would imagne the On1 team has some method for prioritizing interface requsts but I am not privy to that and I don't think anything they have done is shameful.

    0
  • David Kick

    Thanks Brian BTW here's the criteria from the ON1 ideas page

     

     

    And for folks that want to vote for ideas or add a new one here's the link

    https://www.on1.com/products/photo-raw/ideas/

    Another option for folks that want the folder view. There is an option to sort so the subfolders are first and not mixed in with the photos. While in Browse, Select - View - "Sort Subfolders at the top"

     

    0
  • Brian Lawson Community moderator

    Thanks David, I was aware of that. I've made a few suggestions and voted on others. :) The link may be helpful for others here.

    0
  • Terry Loewenberg

    To Brian Lawson - I was in Edit mode. If I let the image fully load (in the main editing window), which takes a good 10-15 seconds, I can delete either by right clicking the mouse and selecting Delete or by tapping the keyboard "Delete."  In that case, ON1 just shifts to next image in the strip and life goes on. My suspicion is it's an interrupt or error trapping issue in the software or both.

    0
  • Brian Lawson Community moderator

    That makes sense to me Terry.

    0
  • Terry Loewenberg

    Brian - If I do a clean uninstall on the Beta version (only version on my desktop at the moment), will it leave the presets, textures, etc behind? I'm trying to avoid having to reinstall all the goodies/freebies and other stuff that I've added. 

    0
  • Brian Lawson Community moderator

    I don't know Terry. On a Mac I would just delete the program's folder. If the uninstaller clears the user data all those goodies will be removed but I do not know if it does that or not.

    0
  • Terry Loewenberg

    Thanks, Brian. I'll look around the forum. 

    0
  • David Kick

    Nigel, glad you found somethting that works for you!

    0
  • Terry Loewenberg

    Brian Lawson - Turns out an "uninstall" is totally destructive. Yup, everything goes.... however, I received an email from ON1 tech support this afternoon that contained the following link that details how to backup user data that you might find useful. Actually, I hope you're never in a situation where you might need it!! 

    https://on1help.zendesk.com/hc/en-us/articles/360004844892-How-to-Install-Save-Manage-and-Back-Up-Presets-in-ON1-Photo-RAW-2018-5-2019

    While I'm here, I also got some feedback on my crashing issue. It was as I expected but wanted to hear from ON1 before jumping with both feet. My PC GPU is a NVIDIA GeForce GT 635... and since it's more than 5 years old, it's ancient compared to day. By hitting the delete key before the image was fully rendered, I was getting dumped. The tech acknowledged that it was probably an interrupt problem in the software. If I waited until the image was fully loaded and deleted it, ON1 is happy and lets me continue. In my reply, I mentioned that I was probably going to shop for a new card, but that ON1 still owed it to their customers to facilitate better interrupt handling. He agreed but that doesn't mean it will be addressed in this round or any other. Frankly, even though annoying, I could live with this issue if ON1 better addressed their lens profile deficiencies. But, that's another story..... TL

    0
  • Brian Lawson Community moderator

    Thanks for the link, Terry.

    0
  • Terry Loewenberg

    Brian - be advised that the process for saving/backing up presets, textures, etc is that you can only export them one at a time. I couldn't find a method for backup "all" in one batch operation. BTW, the crashes gleefully still continue in the maintenance release. I probably already mentioned this in a thread that you are already participating in. I apparently take some satisfaction in complaining. :-)

     

    0
  • Brian Lawson Community moderator

    LOL. I know the feeling.

    0
  • Rick Sammartino Community moderator

    You should be sending all of this to Tech support, no one here can help you.

    https://on1help.zendesk.com/hc/en-us/articles/360018405111-How-to-submit-a-problem-to-ON1-Tech-Support-A-Step-by-step-Guide

    -1

Please sign in to leave a comment.