Skip to main content

On1 2020 constantly accessing NAS drive

Comments

23 comments

  • Brian Lawson Community moderator

    It sounds like you may have created a Catalog for a folder on that drive. The circle is a progress indicator for the cataloging process. Because catalogs are monitored for new images the progress indicator will reappear when that happens.

    0
  • Roger Reading

    How do I control the frequency of checking? I expect it to check when it first comes up and only on request, e.g. import of files.

    My NAS drives are permanently rattling because of ON1 and this is not a satisfactory behaviour for software. This will kill the life of the disks.

    ON1 2019 does not have the same behaviour.

    RR

    0
  • Brian Lawson Community moderator

    You can't. Because photos can be added outside of the program without the use of the Import command will be run whenever the program decides. It is a background process with no controls.

    How long has this been going on? It is possible that the cataloging process has not completely finished regardless of the 100% indicator. It all depends upon how many sub-folders the cataloged folder contains and the depth of them. Cataloging can take a while, especially on a NAS as they tend to be somewhat slower than local drives. Once the cataloging process has finished it should be relatively rare that the background checking takes place.

    0
  • Roger Reading

    I was moving all of my photos to ON1 so catalogued the Lightroom folder to ON1 and after 4 days of constantly rattling the NAS 24 hours a day I gave up. Started it again today and it immendiately started rattling the disks again for a good 5 hours  before I jumped on here for help.

    Sorry forgot to thank you for the quick help which is proving very useful.

    Lightroom has 50K photos in its library and the NAS is a Synology with Gbit ethernet which is not being saturated.

    I am a single user so know exactly when photos get added so don't need this behaviour from ON1 as I know when it needs refreshing. This behaviour needs to be configurable for people like myself. At the moment this product is not usable as it stands.

    RR

    0
  • Roger Reading

    Forgot to mention - I do not use the Cloud products and never will.

    RR

    0
  • Brian Lawson Community moderator

    I don't know what to tell you except that is a core feature of the program's design and the company is probably unlikely to change it. Having said that, you can make a suggestion on the ON1 Photo RAW Project page for other users to vote on. If it receives enough votes the may implement your suggestion.

    0
  • Brian Lawson Community moderator

    When you say you cataloged the Lightroom folder, are you using the migration tool? With 50K images that will take quite a while. If you are not migrating, you will not see the edits made in Lightroom unless you've exported the edited RAW images there to an image format like jpeg or tiff or psd.

    Check out the Lightroom migration document at https://on1help.zendesk.com/hc/en-us/articles/360018410051-Lightroom-Migration-Tool-ON1-Photo-RAW.

    0
  • Roger Reading

    Can you define what quire a while means for 50K images?. 

    It has already been going for 101 hours and my workflow is edit the picture and export as JPEG or TIFF depending on what it is being used for. So did not want the images exported from outlook with the edits held in lightroom.

    If it was exporting I would expect the files to be added to the directory and all I see are *..on1 and *.om1meta files added to the directory for the files.

    Just to test what you said, just removed my Photography folder out of the catalogue and the NAS stopped rattling soon afterwards. Moved my 2020 folder in and it catalogued the folder in no time at all so from that small test did not expect the whole Photography folder to take 101 hours.

    RR

     

    0
  • Brian Lawson Community moderator

    I cannot, check the document I referred you to earlier. It has some estimates.

    That you are seeing .on1meta files tells me you are using the Migration Tool. Those files are created by it and will be removed by the program when it finishes with them.

    My suggestion is to be patient and let the process run its course. Eventually it will finish and the hits to your drive will cease.

    0
  • Roger Reading

    Read the document which states 50K photos with 25% of them edited should take about 7 hours. So looking at the spec of the machine and the bandwidth of the USB2 drive then my machine should be in the same ball park in performance with Gbit lan and a fast Synology which is not even working hard.

    I worked out that mine with 50% edited should take about 24 hours tops - it had been going for 101 hours b hours. Just kicked it off again and will check it in the morning and then tomorrow at 16:11 - 24 hours - to see if it has completed.

    And just to give it a chance will quit all other work on the desktop and move onto the laptop to give it a better chance.

    RR

    0
  • Brian Lawson Community moderator

    Good luck.

    I did not like the performance I got when I tried editing from my NAS so I stuck with the external SSD that holds my images and use the NAS to store backups when I do my importing.

    0
  • Roger Reading

    Well, it now been going for 46 hours and its still rattling away. There are loads of *.on1meta files but some directories still do not have either *.on1 or *.on1meta files in them.

    Not sure what is going on or the expected time to finish.

    RR

    0
  • Brian Lawson Community moderator

    Those directories which do not show any .on1 or .on1meta files haven't been processed yet.

    There isn't any reliable way to know how long it will take. The times given in the article are for a directly connected drive, not an NAS and are only guides. Just let it continue until it is done.

    0
  • Roger Reading

    Well, I thought I would bring you up to date with my conversion from lightroom - it has now been running for 161 hours and still rattling the disks on my Synology NAS. 

    Is there any way of finding out what ON1 is actually doing?

    The PC is only using minimum amount of its power 15-28% CPU and 5.1GB memory 8GB in total available and the Synology is ticking over at 20% and the Ethernet is running at 11Mbps so hardly being used..

    There has been no change over the last 4 days in the mapping of on1 to on1meta files, that is some directories still have neither files appearing and the ones that have them they are still there.

    I am getting very frustrated with this move from Lightroom to ON1 2020.

    0
  • Brian Lawson Community moderator

    I'm going to refer you to ON1's technical support folks. Other than breaking up the migration into smaller pieces rather than trying to do everything all at once I am out of ideas. And that may not solve the problem either.

    Use the Submit a request link below and be sure to include the information requested in this article: https://on1help.zendesk.com/hc/en-us/articles/360018405111-How-to-submit-a-problem-to-ON1-Tech-Support-A-Step-by-step-Guide. I would also include the link to this discussion so they can more easily be brought up to speed on what we've talked about.

    0
  • Roger Reading

    Brian

    Thanks for all the help its has now migrated in 8 hours.

    Solution to the problem: Something had got corrupted during the initial conversion is the only reason for the problem that I can think of.

    I renamed all the caches and log files to .old and started the conversion again last night after reading your document.

    This morning the conversion had finished in 8 hours.

    All working now.

    0
  • Brian Lawson Community moderator

    Good to hear you got things working Roger.

    0
  • Roger Reading

    Brian,

    I spoke too soon :-( the files did not go into 2020 but into 2019. After closing it down and starting it up again it started going rattling the disks again.

    I really do not like how ON1 works. It should not be this hard and this behaviour really needs to be customisable.

    0
  • Brian Lawson Community moderator

    I had to rebuild the catalog on my laptop this week. For 5 days it stood at 99% complete when prior to rebuilding it had finished everything. Last night I found the folder it was hung up on and in that folder was a tiff image it was having problems with. I don't know why, I had edited that tiff previously and it opens without problem in other programs. Moving that file and its .on1 sidecar to my Desktop allowed the cataloging process to finish.

    The way to find the problematic folder is expand the entire folder hierarchy inside the Cataloged folder until you see one with the progress circle on it. Hope this helps.

    0
  • Roger Reading

    Brian, thanks for the hint,

    Expanded all my folders in the catalogue and there are no progress circles either at the top level or on any of the folders underneath it.

    Just before this came in I quit ON1 and it stopped the disk rattling within seconds of issuing the command.

    So it is definately something ON1 is doing wrong. I feel like asking for my money back, even though I like some of the features but this is doing my head in at the moment.

    0
  • Brian Lawson Community moderator

    Have you contacted support about this? My NAS is mounted but I have not cataloged it since all that is there are my original RAW backups from import. I can browse it without the hits to it you are describing.

    It's my guess that the program has run into a problem file somewhere in the Lightroom migration process. When you expanded the hierarchy did you actually browse the folders as you expanded them or did you just click the expansion arrows leaving the browser view on the same folder the whole time? Try walking through them one-by-one. That may cause the progress indicator to be displayed. It may also hang the program if you find one with a file the program is having trouble with. I know it's a PITA but if you can identify a problem image it can be sent to support so a fix can be implemented. At the least you can remove any problem files to allow the program to finish the conversion and cataloging.

    0
  • David Kick

    Roger, You might also try checking the corrupt files log. If you see a file listed move it out of the directory you are trying to catalog.

    You will find it at:

    0
  • Roger Reading

    Brian, David,

    Thanks for the help and hints on possible ways to solve the issue.

    I checked all the logs, my first instinct as a computer professional is to look for errors in log files and also check the windows event folders. I also have a mac notebook which demonstrates the same issues as my Windows desktop. Neither of them show any errors with ON1 corrupt files or any other errors. However, I did find a different error with an e-mail account which was causing an error with an invalid password a few days ago. That problem is now sorted :-)

    I have expanded all the folders under the catalogue down to the lowest level, However, I did not check all the photos in each folder, I will give this a go tomorrow.

    The thing is the last time I did the conversion from Lightroom it finished it in 8 hours and the disks stopped rattling, however the files went into 2019 not 2020. I then closed down 2019 and then restarted 2019 and it seems to go check all the folders again for any changes (my assumption the checking for changes, from the product description). This went on for another 8 hours before it finished. If I left ON1 up and running for the next 100 years i might no see the issue. However, I always shut the system down when I finish at night so each time I start it up again it goes through the hunt again which is unacceptable. This feature should be customisable so that I can decide when to sync with the disks so that the NAS isn't running unnecessarily.

    However, I will give your suggestion a try tomorrow but because of the behaviour I have seen I expect it will finish in 8 hours with no issue.

    I have logged a call with support and they suggested clearing out all caches and start the lightroom conversion again which worked. I have responded to them with the issues again and now waiting for a response from them. 

    0

Please sign in to leave a comment.