Skip to main content

Folders on Hard drive not showing

Comments

4 comments

  • Brian Lawson Community moderator

    You'll need to completely remove ON1 Photo RAW 2020 from your system and reinstall it from scratch. This happens because of how Catalina has split the Macintosh HD into 2 pieces, one that's secure from user changes and the other with all the user's data and installed apps, etc. The OS uses some proprietary voodoo to tie the two pieces back together to present them as a single volume while managing access to the individual pieces behind the scenes.

    Somehow the program's permissions have become screwed up which is why a complete uninstall is required. When it is reinstalled the permissions get set properly and you'll be back in action.

    Be sure you the option to use sidecar files to store your edits is turned on before uninstalling or you'll loose all your edits.

    Delete the following folders:
    1. /Applications/ON1 Photo RAW 2020
    2. /Library/Application Support/ON1
    3. /Library/Frameworks/ON_____.framework
    4. ~/Library/Application Support/ON1  — Make sure to export all your presets first so you can import them after reinstalling
    5. ~/Library/Caches/com.ononesoftware.ON1PhotoRAW____       There are several of these
    6. ~/Library/Caches/ON1 Photo RAW 2020
    7. ~/Library/Preferences/com.ononesoftware.ON1______              There are several of these one for each program module

     

    0
  • John newton

    Thanks, Brian,  Its a pain to have to do it but it solved the problem and everything seems to be back to normal.

    Thanks for the help

    John

    0
  • Robert Lyons

    Hello Brian,

    I just updated my Mac to Catalina 10.15.5 and have the same issue - no local drives visible.  Permission to access photos is still set correctly. Regarding your suggestion #4, I see the "Export Preset" tab, but would I need to select and export each preset individually?  If yes, then wouldn't I lose my organization of presets into categories?  Also, do I need to manually delete each of the above listed libraries?  Will these be automatically reconstituted upon reinstalling ON1?

    I wonder if I could solve this problem if I just deleted and then reinstalled the ON1 application itself.  If so, that would be easier and safer.

     

     

    0
  • Brian Lawson Community moderator

    This is a known problem when upgrading to Catalina when ON1 has already been installed. All you need to do is reinstall on top of your current installation and be sure to give permissions each time you are promoted.

    0

Please sign in to leave a comment.