Skip to main content

I don't see versions since I installed last update (ON1 2021) - Loss of ON1 files



  • Rick Sammartino Community moderator

    I don't have a lot of versions, but I just did a Search through my photos and there are still versions there. I don't know which photos had versions, so if any were lost I wouldn't know.


  • David Kick

    Francois, At least for 1 example I can also say that 2021 is not seeing versions present in 2020.5 see screen shots below. I will submit a support ticket you should also.




  • David Kick

    I confirmed a second version created pre-install of 2021 is not visible in 2021. I did a little test and created a version in 2020.5 and then opened 2021 and that version is visible in 2021 so not sure what's up. Support ticket submitted.


  • Jochen Wienke

    Oh, oh. I came across such a case (not in general to all historical ones) these days as well. Maybe it came just even with the 2nd 2021 version recently. I can see it because I export to go for sure every edited photo with each "final" version into a TIFF. This would be a major bug that would bring me to the question wether I should continue using the software at least editing those images with multiple versions. :-(


  • David Kick


    Are you saying every time you export the file saved is a TIFF?

    If so, I am not seeing the same problem. 

    If you go into the export module you can change the file type by clicking on the drop down arrow.

    Are you using "Export in the background" ? if so you will not get the option to set the file type.

    See pages 195 and 199 in the user guide for detailed instructions.

    User guide can be found here:






  • Jochen Wienke

    Hi David,

    many thanks for your support on this.

    I probably didn't explain well enough.

    What I meant was:

    Once I'm finished with editing, I export in general the edited photo to e.g. TIFF (could be any other format, but without compression of course).

    By that, if sth gets screwed up with the ON1 files and settings, I might still loose all the settings.

    But at least not the final result. Unfortunately in the past it happened already to me that ON1 settings suddenly have been gone. :-(

  • François Vincent

    David Kick thank you for your info. I'm still in the trial version of 2021 so not sure if it is useful to report to support before I decide to go with this version. I wanted to know/understand if the problem is just for me or if it is a general bug.

    David Kick and Jochen Wienke I first try the initial version 2021 and then did the update (but still in trial) and I still have the version 2020 and of course, I did pass from one version to the other as I continue to do my standard work on the 2020 version until I decide to go with the 2021.
    And in fact I wonder if this (passing from one version to another) has created the problem.

    But I was also curious to know if there is way to have ON1 rebuilding all view.


  • Brian Lawson Community moderator

    This was just posted to the Plus forums with regards to lost edits after upgrading to 2021. Thanks to Volker Gottwald.

    This might help and I have done this several times without running into problems.

    Close ON1 PR 2021 and
    – Rename the the directory C:\…\AppData\Roaming\ON1\ON1 Photo RAW 2021\ExploreService to …\_ExploreService
    – Rename the the directory C:\…\AppData\Roaming\ON1\ON1 Photo RAW 2021\NDService to …\_NDService
    (This is for Windows. If you are on a MAC the directory tree may be different.)

    Open ON1 PR 2021
    – Now PR assumes there is no catalog and recreates the two directories that you had renamed and you can start cataloging from scratch.

    The only thing you will loose are albums if you are using this feature. To prevent this from happening you can assign keywords while opening PR 2020 to the files in your albums. These keywords are stored in the sidecar files and accessible with PR 2021. Here you can recreate your albums in line with the newly assigned keywords.

    If this helped you can delete the renamed directories. If it did not help you can delete the newly created directories and rename the renamed ones back to the original name and try to find a solution with support.

  • François Vincent

    Brian Lawson
    Thank you for your message however this didn't solve the problem.

    As mentioned in my original message, I don't use catalogues, I just navigate in folders. However, I did try your "solution" thinking it can only be better.

    But in fact not only it didn't solve the problem but it even destroy what was already solved.

    I have found that if I copy a folder the photo versions will be visible in the new copied folder. Your proposal makes that even in this new copied folders the photo versions are no more visible now :-(

    Having more than 500GB of photos, I didn't consider creating new folders was a solution and I have even not enough room on my hard disk). So I'm back to my original problem/situation :-(

  • Brian Lawson Community moderator

    I'm sorry that didn't work. I was only passing along what another user said had worked for him.

  • François Vincent

    Very strange...
    Just playing in Browse mode to copy folders and/or rename folders/photos and some photo versions appear again but some ".ON1" files have been reset (without entering Edit mode) and I have lost all my work for those photos.

    I feel very unsafe with this version !!??

  • Gerry Fraiberg

    I ran into this issue after updating to on MacOS Big Sur

    All Versions created prior to the update are gone, which means the edit have disappeared. When I tried to created another version of the original .NEF file, it's labelled as V2. That means ON1 recognizes V1, but it's nowhere to be found.

    Tech Support replied with the suggestion to

    "delete the ON1 settings file. Please note that this will not harm any of your images or edits, it simply just clears up any caching issues such as this. To do this you will need to close ON1 and then while holding down the Shift key on your keyboard proceed to relaunch ON1 and continue holding Shift until a pop-up window appears. Here you will need to select to delete the settings file for ON1. After doing so please close ON1 and restart your computer and then re-open ON1 to see if this issue persists."

    Unfortunately this did not fix the issue.



  • Jochen Wienke

    Yes, that was the same with my lost version. Adding a new version would count also up with a higher number as if it was recognized that a version was in between there. However, versions before still dissapeared.

    This is extremely annoying. I like the application and I understand if it has the one or other bug. But where it never should happen is that you loose edits. And it has now happened multiple times in the past since multiple versions. Even if in past sth could be fixed by renaming folders. It seems to happen now accross multiple versions and even same on PC and MAC. How can this one be ignored and seems never tested well enough on any version or sytsem.


  • François Vincent

    So in fact it is not only that I didn't see created version it is that all the work disappear as the ON1 files were reset.

    I was able to get back the ON1 files by restoring previous version (in the Windows File Explorer, right click...).

    However, it is incredible that such a behavior happens only in Browse mode.
    Me too I like the application but it is so non-pro to have such troubles...

    My trial time came over so I will go back with the version 2020 and my bugs (like not working in the second display) and will see what happens with V2021. The pity is that apparently what I already done with V2021 cannot be use in 2020.

  • David Kick

    I just received the response below from On1 support. Looks like moving the photos to a different directory ( probably using the On1 browse module ) resolves the issue. I haven't tested that yet.


    "Our dev team has indicated:

    "...that they are able to reproduce the versions going missing after updating to the latest GM.
    Versions re-appeared once they moved the images to another location. Hopefully this works for the customers experiencing this in the meantime. Versions seem to stay in place when a part of an album, oddly enough..."

  • Gerry Fraiberg

    ON1 is working on a fix for this. It appears that the disappearing versions after update issue is in fact a bug.

    I got this from Tech Support this afternoon:

    "After consulting with our QA team they have deemed this to be a bug in the software.They have written up a report and sent it to our development team so that they can begin working on a patch or update to resolve this. As soon as that patch or update is available for download we will let you know."

    The ON1 team is very responsive. We can complain about bugs, but it is software - with thousands of lines of code, different operating systems and configurations. A good rule is to wait a few weeks to update when a new version is released, to avoid bugs. I don't always follow that rule :-)


  • François Vincent

    Yes, moving photos and/or copying them to another location may make the versions visible again, it is what I wrote in a previous message  (22-Nov 20:59) BUT, I also had some ON1 file reset by "playing" in Browse mode (moving & copying files).

    I'm glad to read that ON1 team is working to solve this bug.
    (however, losing all you work via a correct and standard function is at least strange and I would even say not acceptable)

    So my advice is be careful in order to not lose you work.

  • Roger Salvesen

    I've experienced the same issues after the latest update to PhotoRaw 2021. I lost ALL of my non-destructive edits from all of my cataloged folders. This all started when a screen popped up and said "Connect volume containing on1 photo raw to use this Cataloged Folder. There was a box below which said OK. I clicked OK and ever since my cataloged folders were all messed up. I submitted a request and received instructions from ON1 Technical Support several days ago to try a few different things. The first suggestion didn't resolve the issue. The second suggestion was to do a clean install of ON1 per their instructions which included deleting a couple of ON1 folders. I won't say which ones they were because this didn't resolve the issue either and it actually deleted my previous versions of PhotoRaw 2019 and PhotoRaw 2020 from my computer. 

    After the clean install of PhotoRaw 2021,the non-destructive edits were back in Browse, but all of my cataloged folders got deleted which I assume was because of the folders they instructed me to delete during the clean install. I drag and dropped them back into new cataloged folders and as soon as that happened ALL of the non-destructive edits were GONE. They're gone from both the Browse and Catalog folders section.
    I notified them of what happened and haven't heard back from anyone in two days. Then yesterday, I opened PhotoRaw 2021 to check my cataloged folders and they mysteriously re-appeared. I could actually see when they re-appeared because I went into my files folder in Windows File Explorer and noticed all of the ON1 files were modified on 11/23/20 at 5:51pm. Another one of my cataloged folders was also modified five minutes later at 5:56pm. The previous modified dates for those two folders was on 11/20/20. However, there does seem to be at least one non-destructive edit that didn't re-appear for some reason. There may be more that I'm not aware of because the folders contain several hundred images. I certainly hope they come up with a patch real soon and issue an update. In the future, I will more than likely wait a while before updating and downloading anything from ON1. These type of things should never happen, but unfortunately they do.


  • Carl Traub

    This may not be the same issue that users of 2021 are experiencing, but I had a similar issue in 2020.6. The newly Copied files weren't displaying in the Browse window next to the originals. It turns out that the files existed, and were displayed,  but were sorted to bottom of my Browse window, rather than being next to the original image.

    I found that in the menus, View->Sort->Custom was selected.  I don't know how to tell what the "custom" value was, as there is no information shown there.  After selecting View->Sort->File Name, the "missing" files were displayed next to the originals.

    I don't know whether I had accidentally changed this setting myself, or if it happened during a prior uninstall/reinstall or during the upgrade to 2020.6.

  • Brian Lawson Community moderator

    Custom means the image previews have been dragged around into a "custom" order. At some time you must have moved one around.

  • Jochen Wienke

    Thanks for the input on this. In our specific case however it is really that versions get lost or at least dissapear.

    I have to say that I meanwhile for the first time get quite upset about this issue. How long is this now a known issue alone in this thread and no update came out yet. I really stopped using the application nearly completely to not endager further versions get lost (if not even gone already).

    OK that not every bug can get fixed immediately, but a bug in editings get lost should result in a specific patch within days best not waiting for months to the next feature update. This is really not funny. It happens unfortunately not the first time with this new application that such things happen. There is not much worse then loosing edits!

    In the past (and maybe now?) it helped to copy to a new folder tree but:

    - I think a lot of people have in their daily live beside work, family and other obligations only a limited time for their hobby. It should not be a users task to ongoing come over such issues and look for such solutions if existing at all. If in worst case edits are gone, nothing more has to be said. The big players in this markets also make bugs but they fix it in patches quite soon. However, with loosing edits I have to say, it never happened with any other photo software (and especially not multiple times) like this at all. This is a must-have-perfect-tested. And as said if bug existing "fix immediately"

    - Now I invested time to find out the "solution" like copying to a different folder. But even if versions appear again, what is the deal if meanwhile not a fix is available.. With using next time the application, versions are probably gone already?

    - Additionally, it is not as easy to "simply" copy to different folder structure. I have a sync to a NAS behind which then of course need to delete/copy new all the files between local folders and NAS folders. In one case in the past I really needed to change the parent sync folder, which means even to set up the whole sync settings newly. And with thousands of images behind it takes about nearly a day for me to sync the data each time incl. re-build of catalogues where the application re-builds catalogues and is not usable during that time.

    - ...

    So I'm at the moment frustrated about that this issue seems not to be taken very seriously, don't use much On1 at the moment and during that time look more and more into different solutions. ON1 is really nice and also that you are not forced to upgrade each time. However, practically I would update each time, and then I can go also with major other competitors which are reliable at least your edits aren't gone and such things are taken more seriously. Courious how much time it now will need in addition until this one get fixed.


  • Jochen Wienke

    Small Update:

    Even after upgrading to 2021.1, and moving files to different folder, helps to bring back the lost versions.

    So not sure if they fixed sth at all (nothing explicit mentioned in release notes), or maybe only that no new cases appear. But definitely nothing which would bring back the versions. :-(

  • Gerry Fraiberg

    The latest update - V.2021.1 - appears to have fixed the "missing versions" issue for me. Last week I had an issue with the software hanging. Tech Support advised me to delete the Settings File.

    Then after downloading the 2021.1 update, the missing Versions reappeared. The files were still there when I opened ON1 PR 2020, but they were not visible in ON1 PR 2021.

    I am Mac based and never moved any folders to try to fix the problem.

    While this wasn't on the list of bug fixes, it was a known issue for which a fix was promised for this update.

    Thank you ON1 Development Team!

  • David Kick

    I will +1 re Gerry's latest post. I can now see versions that were created in previous versions if On1 without turning on show subfolders. And as Gerry I have not moved folders to fix. 

    Running Windows 10.


  • Jochen Wienke

    Thanks Gerry and David for sharing this info.

    That makes me hope that at least what we for now on edit will hopefully never be lost.

    Will need to dig in deeeper then what happened on my side.

    The thing is that I basically also can see versions, but somehow not for every file.

    I can see that rather simple across all my pictures since I export all the time with filename + "_on1" once I finished editing. So if I search/see e.g. "v1_on1.jpg" without an original "v1.raf"/"v1.jpg" "original file version" shown I know that a version got lost

    In one example ON1 knew when I added a new version that it is e.g. v4 but without still (even with 2021.1 reappearing v2 and v3)

    However, must dig deeper into it, I recognized that sometimes whole edits (so even the original file(version shows no edit symbol). I use ON1Photo Raw from the beginning on. Maybe I have some losses of older files that came along with upgrading already older versions. Not sure.

    I will also try to delete the config file as it was mentioned above, maybe that comes alöso along with an improvement.


Please sign in to leave a comment.