Skip to main content

ON1 2021.5 update locks up



  • Rick Sammartino Community moderator

    Make sure you run as administrator.

    Also, you might want to re-download it. Your installer could be corrupt.

    How far does the installer get?

  • Donald Laurine

    I just sent in a support request.  I am having the same thing.  I have downloaded the program again, reboot my system, cleared cache, and reloaded three times. I can run sometimes but certain functions do not work. For example... if I check which version I am running using about RAW... the program immediately hangs. I have tried the AI mask and when done it does not always show the mask and I can not edit it again. Then I am running it as a plug-in and the results should I get any do not transfer back to LR. It comes back with the same file as going into RAW.  New Program seems very unstable.


  • David Kick

    Help - "About On1 PhotoRaw" seems to be broken at least on Windows machines. Another user reported they see an error message in the On1 PhotoRaw Log.txt file but I don't see a similar error message but the dialog does not display and the program appears to lockup.

    Note: even though the program seems to lock up all you need to do is click outside of the On1 window and it frees the program up.



  • Brian Lawson Community moderator

    That sounds like the program is making the window active but it just isn't visible. Clicking outside of it clears it normally and the program continues running.

  • David Kick

    Yeah I agree Brian, ( you have to click outside the main On1 Window for example click on the task bar )  I also notice ( Windows 10 ) that the splash screen does not display at startup either. After noticing that I went back in and do see the error message " UpdateLayeredWindowIndirect failed for ptDst=(825, 447), size=(909x545), dirty=(909x545 0, 0) (The parameter is incorrect.)" right after program startup.  After seeing that I double checked and see the same error when I try the Help About function.

    For some reason the Splash Screen error does not lock the program up, probably because it finishes running startup functions after it tries to display the On1 splash screen.


Please sign in to leave a comment.