Skip to main content

Advanced Search not finding some photos

Comments

9 comments

  • Rick Sammartino Community moderator

    Try changing 'Search cataloged Folders' to 'Search All Photos'. I seem to remember this happening before and it might be a bug.

    0
  • David Kick

    I tried that Rick but same result. I can find two specific folders that won't return results with key words. I haven't tried other parameters yet.

    0
  • Brian Lawson Community moderator

    Try renaming those 2 folders. The name change will force the program to rescan the contents of those folders. You can change the name back.

    0
  • David Kick

    Interesting, Renaming the folders did not help. Searching for "Camera/Camera Model" will return results for the folders in question but searching for a keyword does not. I can add a new keyword and then Search will return results for that new keyword but will not return results for old keywords. If I search for Everything/Contains/Lighthouse then the images in the folders in question with the keyword lighthouse are displayed in the search result.

    0
  • Rick Sammartino Community moderator

    Have you looked at the keywords that don't work? Any chance they've been corrupted somehow? For example an extra leading space or something like that?

    0
  • David Kick

    Yes, they all look OK and for example I have the Keyword Duluth in multiple folders and of those there are three folders with images with the Duluth keyword that do not show up in search when searching for the keyword Duluth and all the other images in other folders do but they do show up if I search for Everthing/contains/Duluth. Why show up with Everything/Contains but not with Keyword/Contains?? It's a head scratcher.

    0
  • Brian Lawson Community moderator

    What do you see when you look at the Keyword List? The keywords the program recognizes as being associated with that photo will be highlighted. You may have to move to a different photo and back to force a refresh of the list UI before the highlights will show up. Is there anything in it that shouldn't be there highlighted or not?

    0
  • Gerry Whitmarsh

    I had similar issues. Renaming folders didn't help me either, but physically moving the folders to another location, waiting a while and moving them back seemed to restore most of the missing links between the photo and keyword list.

    0
  • David Kick

    Keywords associated with the photos are highlighted keyword list & the count of photos with that keyword are also correct.  Moving the folders did not help.  I still think it's odd that a search for Everything/Contains finds the photos but Keywords/Contains does not. I guess I will submit a ticket and in the interim just use the search Everything/Contains.

    0

Please sign in to leave a comment.