Skip to main content

Smart Album issue (or user issue!)

Answered

Comments

5 comments

  • Rick Sammartino Community moderator

    The problem is that Search doesn't allow you to select AND or OR on a per line basis. Instead you have to choose AND or OR for the whole list of criteria. That means you have to set up all of the criteria to match either AND or OR but not a mix of the two.

    So in order to select all RAW, TIFF and PSDs that are Yellow, the easiest way is to search for Yellow AND NOT JPG AND NOT PNG AND NOT Onphoto etc.

    Like this...

     
     
    And before you complain about how tricky this is, it's WAY better than what we had before 2022.
    1
  • Brian Lawson Community moderator

    When you set the Match parameter to All you're essentially saying condition 1 AND condition 2 AND condition 3…. No 1 file can be a JPG and a RAW and a TIFF and a PSD. They are mutually exclusive conditions since only one of them can be true for an individual file.

    Try searching for "is not" for all the file types you do not want to see. You might have to change the Match setting to Any.

    0
  • Terry P

    Oops, I should have mentioned I understand why I get zero images back. I did try your suggestion, essentially backing into the search by eliminating the other choices, but it didn't change anything. Match "any" doesn't work because it brings back all images. It's all based on logic so the "and" and "or" parameters need to be set in between each criteria. This is pretty basic. I will create two other smart albums containing only psd and tiff images. At least I'll have the images I want in one place although in different albums. Pretty big limitation in "advanced" search, though. I'll Submit a Problem or suggest this for future versions. Thanks, Brian.  

    0
  • Brian Lawson Community moderator

    Do both. 😎

    0
  • Terry P

    That worked. No complaints. In addition to what I excluded I also included "is "RAW" in the same search so  that's why it didn't work. Eliminating all other file types works. Thanks, Rick. 

    Terry 

    0

Please sign in to leave a comment.