Skip to main content

No AI mask applied to filters

Comments

10 comments

  • David Kick

    OK guys I see what's going on. I am getting a mask applied but it's almost like the default opacity of the AI mask is extremely low with no way to change it. As David Tillet mentioned somewhere else I had to use the Levels slider on the mask to get it to barely appear.

    Steps:
    1:Add Filter
    2: Hover mouse over "Animal" radial and it highlights the bird red.
    3: Click "Animal" Radial and bird highlights blue
    4: Select any filter ( in this example Blur )
         Filter is applied but no mask is visible
    5: Pull mask "Levels: center radial all the way to the left and masking effect is barely visible.
    Images below are in order of these step last image has mask inverted to see the effect on the bird better.


     

    1
  • Rick Sammartino Community moderator

    I have the same problem, but I'm not sure if I'm just not using it properly. I need to do more research on it.

    0
  • Rick Sammartino Community moderator

    Hmmm, I never did anything other than restart the program a few times and now the mask selections are being applied correctly.

    0
  • David Kick

    Reset the program and it still doesn't work on the image above which is a Canon CR2 file but tested it on some jpgs and it works fine. Tried a couple of other .CR2 raw files and some work and some don't. I guess maybe a clean install will work. 

    0
  • Jim Durfee

    Same here Rick, I restarted a few times and then just re-installed and about everything seems to be working for the most part now. I did have to go into the nvidia panel and reset all those settings to.

    This is a major upgrade and with all the AI additions I'm sure I'll find a few more bugs, but all in all I am quite impressed at this versions leap forward!

    0
  • Brian Lawson Community moderator

    David, you applied the mask in Effects then went looking for it in Local Adjustments. Did you tell it to specifically use the mask in a Local Adjustment?

    First you run the mouse pointer over what you want a mask created for then you click on it. This is when you see it in blue. You now have the option of adding additional areas to the mask (not needed in this case) or Control-clicking on the mask to tell the program where you want to see it — in an Effect or a Local Adjustment.

    I've found that I cannot use my Wacom tablet to choose where the mask is to be applied. I cannot pull up the pop-up menu from the Control-click. I can use the tablet to define the mask but then I have to use the trackpad or a mouse to get to the menu.

    This example came from a CR2 file and I've use CR3 files as well so it isn't a problem with the type of raw file you're editing.

    0
  • David Kick

    Brian I am not sure how you gathered that I "applied the mask in Effects then went looking for it in Local Adjustments" if you look at my two images I am in Effects at all times. After some testing I can make this work on all JPGs I have tested and some CR2 files but not others ( all CR2 are from the same camera ) it's very odd. I haven't tested with my wacom yet.

    0
  • Brian Lawson Community moderator

    You had the Effects panel open when you set the mask type. If all you did was select the mask type and not choose a Filter for it to be placed in then it gets discarded.

    You can also apply them in the Mask Options for whatever Local Adjustment or Effects filter you want. You approach it from the other direction so to speak. Choose a filter like Dynamic Contrast, open the Mask Options and choose the type of mask you want created.

    You have to hi the Apply button or it will be discarded again.

    0
  • Brian Lawson Community moderator

    I'm sorry, I misread the second screen shot to be a Local Adjustment. Sorry about that.

    0
  • David Tillett
    Great answers

    I have seen a similar problem. Seems to be down to the issues with how the initial rough mask as shown by blue outline is refined into the final mask. I supplied On1 with a test image showing this during the beta process. Hopefully it will be resolved soon. I guess that there will be a 2023.0.1 minor release with additional bug fixes coming out in the next few weeks as has happened in previous years.

    0

Please sign in to leave a comment.